You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
It looks like invoke only works up to Python 3.11. Is there any interest in moving up to later version of python? This is a great project and I haven't found a replacement for it! Please maintain it.
Not sure if there was a particular problem @tianhuil was having, but at the very least the classifier list and test environments do not go past Python 3.11 and should probably be updated to include those newer versions.
from patchwork.files import exists
File "/home/kabira/Development/cloudworks-monallabs/patchwork/patchwork/files.py", line 7, in <module>
from invoke.vendor import six
ImportError: cannot import name 'six' from 'invoke.vendor' (/home/adming/Execution/cloudworks/venv/lib/python3.12/site-packages/invoke/vendor/__init__.py)
@sandeep-gh that looks like a version problem, the main branch of invoke doesn't vendorize six, so you might need to get a different version of invoke, either one provided by the project you're using or an older version, or update the project you're using
If you're hitting a concrete failure on a specific 3.12/3.13/3.14 setup that's not already covered by a more recent issue (e.g. #1052 for one remaining 3.14 PTY case), it'd help to reopen with a minimal repro and the failing version. Otherwise this one looks safe to close.
Drive-by triage from an outside contributor (data engineer GCP/Python, jbbqqf). Comment drafted with Claude assistance; evidence and conclusion are mine. Happy to be told I missed something.
Activity
alwaysmpe commentedon Nov 22, 2024
What problem are you having? I'm using invoke on 3.13 without problems (although the type annotations need refining) so it at least partially works
SnoopJ commentedon Dec 3, 2024
Not sure if there was a particular problem @tianhuil was having, but at the very least the classifier list and test environments do not go past Python 3.11 and should probably be updated to include those newer versions.
sandeep-gh commentedon Jan 16, 2025
i am having this issue with python 3.12:
alwaysmpe commentedon Jan 16, 2025
@sandeep-gh that looks like a version problem, the main branch of invoke doesn't vendorize
six, so you might need to get a different version ofinvoke, either one provided by the project you're using or an older version, or update the project you're usingsandeep-gh commentedon Jan 16, 2025
yes, my bad. Its the patchwork module that has not been updated and is causing the problem.
schwaerz commentedon Feb 13, 2025
There is a rather old ticket about one thing that does not work when running invoke in Windows with python 3.12+: #571
As soon as you are trying to use any binary installed from pypi, invoke won't find them anymore with 3.12+.
jbbqqf commentedon May 24, 2026
Hi @tianhuil — drive-by triage check: I think this can be closed as resolved.
Python 3.12, 3.13 and 3.14 are all supported on current
main:pyproject.tomldeclaresrequires-python = ">=3.9"and ships classifiers up throughProgramming Language :: Python :: 3.14..circleci/config.ymlruns the test matrix on["3.10", "3.11", "3.12", "3.13", "3.14"].fcntl/TIOCGWINSZbehavior) was fixed in 2.1.4 via handle TIOCGWINSZ struct correctly #1040 — see the changelog.If you're hitting a concrete failure on a specific 3.12/3.13/3.14 setup that's not already covered by a more recent issue (e.g. #1052 for one remaining 3.14 PTY case), it'd help to reopen with a minimal repro and the failing version. Otherwise this one looks safe to close.
Drive-by triage from an outside contributor (data engineer GCP/Python, jbbqqf). Comment drafted with Claude assistance; evidence and conclusion are mine. Happy to be told I missed something.