Implemetation some algorithms from RFC's.
RFC 6114 The 128-Bit Blockcipher CLEFIA
Cipher algorithm with 16 byte block and 128/192/256-bit key.
RFC 8439 ChaCha20 and Poly1305 for IETF Protocols
AEAD algorithm with ChaCha20 cipher and Poly1305 MAC.
RFC 8682 TinyMT32 Pseudorandom Number Generator (PRNG)
PRNG with period 2^127 - 1 and 127-bit internal state size.